<!DOCTYPE html>
<!--[if lt IE 7]> <html class="lt-ie9 lt-ie8 lt-ie7" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 7]>    <html class="lt-ie9 lt-ie8" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if IE 8]>    <html class="lt-ie9" lang="en-US" prefix="og: http://ogp.me/ns#"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: http://ogp.me/ns#"> <!--<![endif]-->
<head>
<meta http-equiv="content-type" content="text/html; charset=UTF-8">
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<title>So So Def Turns 25 - Support Our Troops - Stomp And Stammer</title>
<link rel="profile" href="http://gmpg.org/xfn/11">

<link rel="pingback" href="http://stompandstammer.com/wp16/xmlrpc.php">
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">

<meta name="HandheldFriendly" content="True">
<meta name="apple-touch-fullscreen" content="yes" />
<meta name="MobileOptimized" content="320">
<link rel="pingback" href="http://stompandstammer.com/wp16/xmlrpc.php">

			<script type="text/javascript">
				addthis_config = {
										ui_click: false,
					ui_delay: 100,
					ui_offset_top: 42,
					ui_use_css: true,
					data_track_addressbar: false,
					data_track_clickback: false
									};

				addthis_share = {
					url: "http://stompandstammer.com/support-our-troops/def-turns-25/",
					title: "So So Def Turns 25 - Support Our Troops - Stomp And Stammer",
					description: ""
				};
			</script>
			
<!-- This site is optimized with the Yoast SEO plugin v6.0 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://stompandstammer.com/support-our-troops/def-turns-25/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="So So Def Turns 25 - Support Our Troops - Stomp And Stammer" />
<meta property="og:description" content="2018 marks 25 years since Atlanta musician/songwriter/producer Jermaine Dupri founded . . ." />
<meta property="og:url" content="http://stompandstammer.com/support-our-troops/def-turns-25/" />
<meta property="og:site_name" content="Stomp And Stammer" />
<meta property="article:publisher" content="https://www.facebook.com/StompAndStammer/" />
<meta property="article:tag" content="Atlanta" />
<meta property="article:tag" content="Bow Wow" />
<meta property="article:tag" content="Da Brat" />
<meta property="article:tag" content="Georgia" />
<meta property="article:tag" content="Hip-Hop" />
<meta property="article:tag" content="Jagged Edge" />
<meta property="article:tag" content="Jermaine Dupri" />
<meta property="article:tag" content="Kris Kross" />
<meta property="article:tag" content="Rap" />
<meta property="article:tag" content="Rhythm and Blues" />
<meta property="article:tag" content="So So Def" />
<meta property="article:tag" content="Xscape" />
<meta property="article:section" content="Support Our Troops" />
<meta property="article:published_time" content="2018-02-26T19:10:35-05:00" />
<meta property="article:modified_time" content="2018-02-26T19:12:29-05:00" />
<meta property="og:updated_time" content="2018-02-26T19:12:29-05:00" />
<meta property="og:image" content="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/jermaine.jpg" />
<meta property="og:image:width" content="1050" />
<meta property="og:image:height" content="600" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="2018 marks 25 years since Atlanta musician/songwriter/producer Jermaine Dupri founded . . ." />
<meta name="twitter:title" content="So So Def Turns 25 - Support Our Troops - Stomp And Stammer" />
<meta name="twitter:site" content="@stompandstammer" />
<meta name="twitter:image" content="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/jermaine.jpg" />
<meta name="twitter:creator" content="@stompandstammer" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"http:\/\/stompandstammer.com\/","name":"Stomp And Stammer","potentialAction":{"@type":"SearchAction","target":"http:\/\/stompandstammer.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s7.addthis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Stomp And Stammer &raquo; Feed" href="http://stompandstammer.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Stomp And Stammer &raquo; Comments Feed" href="http://stompandstammer.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/stompandstammer.com\/wp16\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.4"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='yarppWidgetCss-css'  href='http://stompandstammer.com/wp16/wp-content/plugins/yet-another-related-posts-plugin/style/widget.css?ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-general-css'  href='http://stompandstammer.com/wp16/wp-content/plugins/woocommerce/assets/css/woocommerce.css?ver=3.2.6' type='text/css' media='all' />
<link rel='stylesheet' id='wpgrade-woocommerce-css'  href='http://stompandstammer.com/wp16/wp-content/themes/bucket/theme-content/css/woocommerce.css?ver=201705200148' type='text/css' media='all' />
<link rel='stylesheet' id='google-webfonts-css'  href='http://fonts.googleapis.com/css?family=Arvo%3A400%2C700%2C400italic%2C700italic%7CPT+Sans%3A400%2C700%2C400italic%2C700italic%7COpen+Sans%3A400%2C700&#038;ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='wpgrade-main-style-css'  href='http://stompandstammer.com/wp16/wp-content/themes/bucket/theme-content/css/style.css?ver=1.6.6' type='text/css' media='all' />
<style id='wpgrade-main-style-inline-css' type='text/css'>

                        #text-3 .widget__title { display: none; }
.header--type2 .nav--top-right { display: none; }
.header--type3 .nav--top-right { display: none; }
.product_type_add_to_cart_button { display: none; }                    

</style>
<link rel='stylesheet' id='pixlikes-plugin-styles-css'  href='http://stompandstammer.com/wp16/wp-content/plugins/pixlikes/css/public.css?ver=1.0.0' type='text/css' media='all' />
<style id='pixlikes-plugin-styles-inline-css' type='text/css'>
.animate i:after {-webkit-transition: all 1000ms;-moz-transition: all 1000ms;-o-transition: all 1000ms;transition: all 1000ms; }
</style>
<link rel='stylesheet' id='woocommerce-layout-css'  href='http://stompandstammer.com/wp16/wp-content/plugins/woocommerce/assets/css/woocommerce-layout.css?ver=3.2.6' type='text/css' media='all' />
<link rel='stylesheet' id='woocommerce-smallscreen-css'  href='http://stompandstammer.com/wp16/wp-content/plugins/woocommerce/assets/css/woocommerce-smallscreen.css?ver=3.2.6' type='text/css' media='only screen and (max-width: 768px)' />
<link rel='stylesheet' id='bucket-child-style-css'  href='http://stompandstammer.com/wp16/wp-content/themes/bucket-child/style.css?ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://stompandstammer.com/wp16/wp-content/plugins/jetpack/css/jetpack.css?ver=5.7' type='text/css' media='all' />
<script type='text/javascript' src='http://stompandstammer.com/wp16/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://stompandstammer.com/wp16/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='http://stompandstammer.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://stompandstammer.com/wp16/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://stompandstammer.com/wp16/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.4" />
<meta name="generator" content="WooCommerce 3.2.6" />
<link rel='shortlink' href='http://stompandstammer.com/?p=8036' />
<link rel="alternate" type="application/json+oembed" href="http://stompandstammer.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fstompandstammer.com%2Fsupport-our-troops%2Fdef-turns-25%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://stompandstammer.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fstompandstammer.com%2Fsupport-our-troops%2Fdef-turns-25%2F&#038;format=xml" />

<!-- This site is using AdRotate v4.8 to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

			<script type="text/javascript">
				if (typeof WebFont !== 'undefined') {					WebFont.load({
						google: {families: ['Arvo:regular:latin','PT Sans:regular:latin-ext','PT Sans:regular,italic,700,700italic:latin-ext']},
						classes: false,
						events: false
					});
				} else {
					var tk = document.createElement('script');
					tk.src = '//ajax.googleapis.com/ajax/libs/webfont/1/webfont.js';
					tk.type = 'text/javascript';

					tk.onload = tk.onreadystatechange = function () {
						WebFont.load({
							google: {families: ['Arvo:regular:latin','PT Sans:regular:latin-ext','PT Sans:regular,italic,700,700italic:latin-ext']},
							classes: false,
							events: false
						});
					};

					var s = document.getElementsByTagName('script')[0];
					s.parentNode.insertBefore(tk, s);
				}
			</script>
				<style id="customify_typography_output_style">
			.badge, h1, h2, h3, h4, h5, h6, hgroup,
									.hN, .article__author-name, .comment__author-name,
									.score__average-wrapper, .score__label,
									.widget_calendar caption, blockquote,
									.tabs__nav, .popular-posts__time,
									.heading .hN, .widget--sidebar__title .hN,
									.widget--footer__title .hN, .heading .article__author-name,
									.widget--sidebar__title .article__author-name,
									.widget--footer__title .article__author-name,
									.heading .comment__author-name,
									.widget--sidebar__title .comment__author-name,
									.widget--footer__title .comment__author-name,
									.heading .score__average-wrapper,
									.widget--sidebar__title .score__average-wrapper,
									.widget--footer__title .score__average-wrapper,
									.heading .score__label, .widget--sidebar__title .score__label,
									.widget--footer__title .score__label, .heading .widget_calendar caption,
									.widget_calendar .heading caption,
									.widget--sidebar__title .widget_calendar caption,
									.widget_calendar .widget--sidebar__title caption,
									.widget--footer__title .widget_calendar caption,
									.widget_calendar .widget--footer__title caption,
									.score-box--after-text, .latest-comments__author,
									.review__title, .share-total__value, .pagination li a, .pagination li span,
									.heading span.archive__side-title {
 font-family: Arvo;
font-weight: normal;
}
nav {
 font-family: PT Sans;
font-weight: normal;
}
html, .wp-caption-text, .small-link,
									.post-nav-link__label, .author__social-link,
									.comment__links, .score__desc {
 font-family: PT Sans;
}
		</style>
	<style type='text/css'>img#wpstats{display:none}</style>	<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
	<meta name="description" content="2018 marks 25 years since Atlanta musician/songwriter/producer Jermaine Dupri founded . . ."/>
<link rel="canonical" href="http://stompandstammer.com/support-our-troops/def-turns-25/" />
<!-- facebook open graph stuff -->

<meta property="og:site_name" content="Stomp And Stammer"/>
<meta property="og:url" content="http://stompandstammer.com/support-our-troops/def-turns-25/"/>
<meta property="og:title" content="So So Def Turns 25 - Support Our Troops - Stomp And Stammer" />
<meta property="og:type" content="article"/>
<meta property="og:description" content="2018 marks 25 years since Atlanta musician/songwriter/producer Jermaine Dupri founded . . ." />
<meta property="article:published_time" content="2018-02-26">
<meta property="article:section" content="Support our troops">
<meta property="article:tag" content="Atlanta">
<meta property="article:tag" content="Bow Wow">
<meta property="article:tag" content="Da Brat">
<meta property="article:tag" content="Georgia">
<meta property="article:tag" content="Hip-Hop">
<meta property="article:tag" content="Jagged Edge">
<meta property="article:tag" content="Jermaine Dupri">
<meta property="article:tag" content="Kris Kross">
<meta property="article:tag" content="Rap">
<meta property="article:tag" content="Rhythm and Blues">
<meta property="article:tag" content="So So Def">
<meta property="article:tag" content="Xscape">
<meta property="og:image" content="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/jermaine.jpg"/>
<!-- end facebook open graph --><!-- google +1 tags -->
<meta itemprop="name" content="So So Def Turns 25">
<meta itemprop="description" content="2018 marks 25 years since Atlanta musician/songwriter/producer Jermaine Dupri founded . . .">
<meta itemprop="image" content="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/jermaine.jpg">

<!-- end google +1 tags --><!-- twitter card tags -->
<meta name="twitter:card" content="summary">
<meta name="twitter:url" content="http://stompandstammer.com/support-our-troops/def-turns-25/" >
<meta name="twitter:site" content="@stompandstammer"/>
<meta name="twitter:domain" content="stompandstammer.com">
<meta name="twitter:title" content="So So Def Turns 25">
<meta name="twitter:description" content="2018 marks 25 years since Atlanta musician/songwriter/producer Jermaine Dupri founded . . .">
<meta name="twitter:image:src" content="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/jermaine.jpg">
<!-- end twitter card tags -->
		<style id="customify_output_style">
		
a, blockquote, .small-link, .tabs__nav a.current,
.popular-posts__time a.current, .tabs__nav a:hover,
.popular-posts__time a:hover, .widget--footer__title em,
.widget_rss .widget--footer__title .hN,
.widget_rss .widget--footer__title .article__author-name,
.widget_rss .widget--footer__title .comment__author-name,
.widget_rss .widget--footer__title .widget_calendar caption,
.widget_calendar .widget_rss .widget--footer__title caption,
.widget_rss .widget--footer__title .score__average-wrapper,
.widget_rss .widget--footer__title .score__label,
.article--billboard-small .small-link em,
.article--billboard-small .post-nav-link__label em,
.article--billboard-small .author__social-link em,
.small-link, .post-nav-link__label, .author__social-link,
.article--thumb__title a:hover,
.widget_wpgrade_twitter_widget .widget--footer__title h3:before,
a:hover > .pixcode--icon,
.score__pros__title, .score__cons__title,
.comments-area-title .hN em,
.comment__author-name, .woocommerce .amount,
.panel__title em, .woocommerce .star-rating span:before,
.woocommerce-page .star-rating span:before{
		color: #fb4834;
}
.heading--main .hN, .widget--sidebar__title,
.pagination .pagination-item--current span,.pagination .current, .single .pagination span,
.pagination li a:hover, .pagination li span:hover,
.rsNavSelected, .badge, .progressbar__progress,
.btn:hover, .comments_add-comment:hover,
.form-submit #comment-submit:hover,
.widget_tag_cloud a:hover, .btn--primary,
.comments_add-comment, .form-submit #comment-submit,
a:hover > .pixcode--icon.circle, a:hover > .pixcode--icon.square,
.article--list__link:hover .badge, .score__average-wrapper,
.site__stats .stat__value:after, .site__stats .stat__title:after,
.btn--add-to-cart, .social-icon-link:hover .square, .social-icon-link:focus .square,
.social-icon-link:active .square,
.site__stats .stat__value:after, .site__stats .stat__title:after{
		background-color: #fb4834;
}
.woocommerce ul.products li.product a:hover img{
		border-bottom-color: #fb4834;
}
ol{
		border-left-color: #fb4834;
}
nav a { font-size: 13px; }
.article, .single .main, .page .main,
.comment__content,
.footer__widget-area { font-size: 16px; }
body, .article, .single .main, .page .main,
.comment__content,
.footer__widget-area { line-height: 1.6; }
@media only screen and (min-width: 900px) { .nav--main li:hover, .nav--main li.current-menu-item{
		border-bottom-color: #fb4834;
}
 }
@media  only screen and (min-width: 900px) { .back-to-top a:hover:after, .back-to-top a:hover:before{
		border-color: #fb4834;
}
 }
@media only screen and (min-width: 900px)  { .article--billboard > a:hover .article__title:before,
.article--billboard > a:hover .article--list__title:before,
.article--billboard > a:hover .latest-comments__title:before,
.article--grid__header:hover .article--grid__title h3,
.article--grid__header:hover .article--grid__title:after{
		background-color: #fb4834;
}
 }

		</style><!-- BEGIN GADWP v5.1.2.5 Universal Analytics - https://deconf.com/google-analytics-dashboard-wordpress/ -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-81885785-1', 'auto');
  ga('send', 'pageview');
</script>
<!-- END GADWP Universal Analytics -->
<script type="text/javascript">
;(function($){
                                            
})(jQuery);
</script>
</head>
<body class="post-template-default single single-post postid-8036 single-format-standard  sticky-nav" itemscope itemtype="http://schema.org/WebPage">
    <div class="pace">
        <div class="pace-activity"></div>
    </div>
    <div id="page">
        <nav class="navigation  navigation--mobile  overthrow">
            <h2 class="accessibility">Primary Mobile Navigation</h2>
            <div class="search-form  push-half--top  push--bottom  soft--bottom">
                <form class="form-search" method="get" action="http://stompandstammer.com/" role="search">
    <input class="search-query" type="text" name="s" id="s" placeholder="Search..." autocomplete="off" value="" /><!--
    --><button class="btn search-submit" id="searchsubmit"><i class="icon-search"></i></button>
</form>            </div>
            <ul id="menu-header-menu" class="nav  nav--main"><li id="menu-item-289" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-289"><a href="http://stompandstammer.com/">Home</a></li>
<li id="menu-item-332" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-332"><a href="http://stompandstammer.com/category/feature-stories/">Feature Stories</a></li>
<li id="menu-item-334" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-334"><a href="http://stompandstammer.com/category/record-reviews/">Record Reviews</a></li>
<li id="menu-item-333" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-333"><a href="http://stompandstammer.com/category/movie-reviews/">Movie Reviews</a></li>
<li id="menu-item-5660" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5660"><a href="http://stompandstammer.com/category/book-reviews/">Book Reviews</a></li>
<li id="menu-item-5663" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-5663"><a href="http://stompandstammer.com/category/news-leak/">Music News &#038; More&#8230;</a>
<ul class="sub-menu">
	<li id="menu-item-4618" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4618"><a href="http://stompandstammer.com/category/news-leak/">News Leak</a></li>
	<li id="menu-item-7704" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-7704"><a href="http://stompandstammer.com/category/support-our-troops/">Support Our Troops</a></li>
	<li id="menu-item-5650" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5650"><a href="http://stompandstammer.com/category/call-sheet/">Call Sheet</a></li>
	<li id="menu-item-2868" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2868"><a href="http://stompandstammer.com/category/concert-calendar/">Get Out!</a></li>
	<li id="menu-item-7705" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7705"><a href="http://bandsiusetalike.com">Bands I Useta Like</a></li>
</ul>
</li>
</ul>        </nav>
        <div class="wrapper">
            <header class="header header--type2">

    <nav class="navigation  navigation--top">

        <div class="container">
            <h2 class="accessibility">Secondary Navigation</h2>
			
            <div class="grid">
                <div class="grid__item one-half">
                                    </div><!--
             --><div class="grid__item one-half text--right">
                    <ul class="header-bar header-bar--top nav flush--bottom"><!--
				     --><li></li><!--
                     --><li>			<li>
				<a class="social-icon-link" href="https://twitter.com/stompandstammer" target="_blank">
					<i class="pixcode  pixcode--icon  icon-e-twitter square"></i>
				</a>
			</li>
					<li>
				<a class="social-icon-link" href="https://www.facebook.com/Stomp-and-Stammer-26104709043/" target="_blank">
					<i class="pixcode  pixcode--icon  icon-e-facebook square"></i>
				</a>
			</li>
		</li><!--
                                             --><li><form class="form-search" method="get" action="http://stompandstammer.com/" role="search">
    <input class="search-query" type="text" name="s" id="s" placeholder="Search..." autocomplete="off" value="" /><!--
    --><button class="btn search-submit" id="searchsubmit"><i class="icon-search"></i></button>
</form></li><!--
                                         --></ul>
                </div>
            </div>
        </div>

    </nav>

    <div class="container">

        <div class="site-header flexbox">
            <div class="site-header__branding  flexbox__item  one-whole  lap-and-up-three-tenths">
                    <a class="site-logo  site-logo--image  " href="http://stompandstammer.com" title="Stomp And Stammer">
                <img src="http://stompandstammer.com/wp16/wp-content/uploads/2016/03/stomp-logo.jpg"  rel="logo" alt="Stomp And Stammer"/>
    </a>

            </div><!--
            -->			<div class="header-ad  flexbox__item  one-whole  lap-and-up-seven-tenths">
                                        <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Header - Responsive -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6681116909085824"
     data-ad-slot="8220330996"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>                                </div>
			        </div>

        <div class="site-navigation__trigger js-nav-trigger"><span class="nav-icon"></span></div>                
        
		<hr class="nav-top-separator separator separator--subsection flush--bottom" />
		
        <nav class="navigation  navigation--main  js-navigation--main">
            <h2 class="accessibility">Primary Navigation</h2>
            <div class="nav--main__wrapper  js-sticky">
                <ul id="menu-header-menu-1" class="nav  nav--main  js-nav--main">
<li id="nav--top__item-289" class="nav__item depth-0 menu-item menu-item-type-post_type menu-item-object-page menu-item-home hidden"><a href="http://stompandstammer.com/" class="menu-link main-menu-link">Home</a></li>
<li id="nav--top__item-332" class="nav__item depth-0 menu-item menu-item-type-taxonomy menu-item-object-category hidden">
<a href="http://stompandstammer.com/category/feature-stories/" class="menu-link main-menu-link">Feature Stories</a><div class="sub-menu--mega"><div class="sub-menu__grid  grid  grid--thin">
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://stompandstammer.com/feature-stories/dixie-dregs/"><div class="article__thumb" style=""><img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/dixie_dregs_current-203x157.jpg" alt="Dixie Dregs" width="203" height="157" class=" lazy "></div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">Dixie Dregs</span></h2>
											<div class="article__description">Dixie Dregs Answer the Question: “What If?” Atlanta (by way . . .</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://stompandstammer.com/feature-stories/delbert-mcclinton/"><div class="article__thumb" style=""><img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/delbert_mcclinton_todd_v_wolfson-203x157.jpg" alt="Delbert McClinton" width="203" height="157" class=" lazy "></div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">Delbert McClinton</span></h2>
											<div class="article__description">Self-Made Man: Give It Up for Delbert McClinton The term . . .</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://stompandstammer.com/feature-stories/marillion/"><div class="article__thumb" style=""><img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/marillion_freddy_billqvis-203x157.jpg" alt="Marillion" width="203" height="157" class=" lazy "></div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">Marillion</span></h2>
											<div class="article__description">Fuck Me? Fuck You! Fuck Marillion? Fuck Everyone! The heyday . . .</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://stompandstammer.com/feature-stories/tennis/"><div class="article__thumb" style=""><img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/01/tennis_10-203x157.jpg" alt="Tennis" width="203" height="157" class=" lazy "></div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">Tennis</span></h2>
											<div class="article__description">Everyone’s for Tennis Wife-and-husband team Alaina Moore and Patrick  . . .</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://stompandstammer.com/feature-stories/ben-haggard/"><div class="article__thumb" style=""><img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/01/ben_haggard-203x157.jpg" alt="Ben Haggard" width="203" height="157" class=" lazy "></div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">Ben Haggard</span></h2>
											<div class="article__description">Trusted Name: Ben Haggard Won’t Let the Music Die Meeting . . .</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
</div></div>
</li>
<li id="nav--top__item-334" class="nav__item depth-0 menu-item menu-item-type-taxonomy menu-item-object-category hidden">
<a href="http://stompandstammer.com/category/record-reviews/" class="menu-link main-menu-link">Record Reviews</a><div class="sub-menu--mega"><div class="sub-menu__grid  grid  grid--thin">
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://stompandstammer.com/record-reviews/noel-gallaghers-high-flying-birds-built-moon/"><div class="article__thumb" style=""><img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/cover_ngallagher_moon-203x157.jpg" alt="Noel Gallagher’s High Flying Birds – Who Built the Moon?" width="203" height="157" class=" lazy "></div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">Noel Gallagher’s High Flying Birds – Who Built the Moon?</span></h2>
											<div class="article__description">Noel Gallagher’s third album with High Flying Birds is his . . .</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://stompandstammer.com/record-reviews/go-team-semicircle/"><div class="article__thumb" style=""><img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/cover_goteam_semicircle-203x157.jpg" alt="The Go! Team – Semicircle" width="203" height="157" class=" lazy "></div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">The Go! Team – Semicircle</span></h2>
											<div class="article__description">The Go! Team’s career arc should be required reading for . . .</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://stompandstammer.com/record-reviews/lees-memory-blinding-white-nothing/"><div class="article__thumb" style=""><img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/cover_lees_blinding-203x157.jpg" alt="The Lees of Memory – The Blinding White of Nothing at All" width="203" height="157" class=" lazy "></div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">The Lees of Memory – The Blinding White of Nothing at All</span></h2>
											<div class="article__description">“Because I can” is seldom a well-argued rationale for recording . . .</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://stompandstammer.com/record-reviews/the-used-the-canyon/"><div class="article__thumb" style=""><img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/cover_used_canyon-203x157.jpg" alt="The Used – The Canyon" width="203" height="157" class=" lazy "></div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">The Used – The Canyon</span></h2>
											<div class="article__description">The Used have always been a screaming kid, fake emo, . . .</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://stompandstammer.com/record-reviews/first-aid-kit-ruins/"><div class="article__thumb" style=""><img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/cover_firstaidkit_ruins-203x157.jpg" alt="First Aid Kit – Ruins" width="203" height="157" class=" lazy "></div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">First Aid Kit – Ruins</span></h2>
											<div class="article__description">First Aid Kit might just be the closest thing out there to . . .</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
</div></div>
</li>
<li id="nav--top__item-333" class="nav__item depth-0 menu-item menu-item-type-taxonomy menu-item-object-category hidden">
<a href="http://stompandstammer.com/category/movie-reviews/" class="menu-link main-menu-link">Movie Reviews</a><div class="sub-menu--mega"><div class="sub-menu__grid  grid  grid--thin">
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://stompandstammer.com/movie-reviews/game-night/"><div class="article__thumb" style=""><img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/game_night-203x157.jpg" alt="Game Night" width="203" height="157" class=" lazy "></div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">Game Night</span></h2>
											<div class="article__description">Copious doses of horse tranquilizers have the same impact as . . .</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://stompandstammer.com/movie-reviews/annihilation/"><div class="article__thumb" style=""><img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/annihilation-203x157.jpg" alt="Annihilation" width="203" height="157" class=" lazy "></div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">Annihilation</span></h2>
											<div class="article__description">Whenever more than one or two film reviewers use the . . .</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://stompandstammer.com/movie-reviews/early-man/"><div class="article__thumb" style=""><img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/early_man-203x157.jpg" alt="Early Man" width="203" height="157" class=" lazy "></div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">Early Man</span></h2>
											<div class="article__description">From Wallace and Gromit creator Nick Park, who’s tackled chickens . . .</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://stompandstammer.com/movie-reviews/peter-rabbit/"><div class="article__thumb" style=""><img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/peter_rabbit-203x157.jpg" alt="Peter Rabbit" width="203" height="157" class=" lazy "></div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">Peter Rabbit</span></h2>
											<div class="article__description">Beatrix Potter is a punk rocker in this updated revenge . . .</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://stompandstammer.com/movie-reviews/black-panther/"><div class="article__thumb" style=""><img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/black_panther-203x157.jpg" alt="Black Panther" width="203" height="157" class=" lazy "></div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">Black Panther</span></h2>
											<div class="article__description">Based around a faulty premise, Black Lives Matter perceives rabid, . . .</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
</div></div>
</li>
<li id="nav--top__item-5660" class="nav__item depth-0 menu-item menu-item-type-taxonomy menu-item-object-category hidden">
<a href="http://stompandstammer.com/category/book-reviews/" class="menu-link main-menu-link">Book Reviews</a><div class="sub-menu--mega"><div class="sub-menu__grid  grid  grid--thin">
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://stompandstammer.com/book-reviews/hit-so-hard/"><div class="article__thumb" style=""><img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/bookcover_schemel-203x157.jpg" alt="Hit So Hard" width="203" height="157" class=" lazy "></div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">Hit So Hard</span></h2>
											<div class="article__description">Hit So Hard By Patty Schemel with Erin Hosier [Da . . .</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://stompandstammer.com/book-reviews/sticky-fingers-life-times-jann-wenner-rolling-stone-magazine/"><div class="article__thumb" style=""><img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/01/bookcover_wenner-203x157.jpg" alt="Sticky Fingers: The Life and Times of Jann Wenner and Rolling Stone Magazine" width="203" height="157" class=" lazy "></div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">Sticky Fingers: The Life and Times of Jann Wenner and Rolling Stone Magazine</span></h2>
											<div class="article__description">Sticky Fingers: The Life and Times of Jann Wenner and . . .</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://stompandstammer.com/book-reviews/woman-walk-line/"><div class="article__thumb" style=""><img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/01/bookcover_womenwalk-203x157.jpg" alt="Woman Walk the Line" width="203" height="157" class=" lazy "></div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">Woman Walk the Line</span></h2>
											<div class="article__description">Woman Walk the Line: How the Women in Country Music . . .</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://stompandstammer.com/book-reviews/leo-fender-quiet-giant-heard-around-world/"><div class="article__thumb" style=""><img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/01/bookcover_fender-203x157.jpg" alt="Leo Fender: The Quiet Giant Heard Around the World" width="203" height="157" class=" lazy "></div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">Leo Fender: The Quiet Giant Heard Around the World</span></h2>
											<div class="article__description">Leo Fender: The Quiet Giant Heard Around the World By . . .</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
<div class="sub-menu__grid__item  grid__item  one-fifth"><article class="article article--billboard-small"><a href="http://stompandstammer.com/book-reviews/everything-is-combustible/"><div class="article__thumb" style=""><img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2017/12/bookcover_rlloyd-203x157.jpg" alt="Everything is Combustible" width="203" height="157" class=" lazy "></div>
<div class="article__content">
											<h2 class="article__title article--billboard-small__title"><span class="hN">Everything is Combustible</span></h2>
											<div class="article__description">Everything is Combustible: Television, CBGB’s and Five Decades of Rock . . .</div>
											<span class="small-link">Read More<em>+</em></span>
										</div>
									</a></article></div>
</div></div>
</li>
<li id="nav--top__item-5663" class="nav__item depth-0 menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item--parent hidden nav__item--relative">
<a href="http://stompandstammer.com/category/news-leak/" class="menu-link main-menu-link">Music News &amp; More…</a><ul class="nav nav--stacked nav--sub-menu sub-menu">
<li id="nav--top__item-4618" class="nav__item depth-1 menu-item menu-item-type-taxonomy menu-item-object-category hidden"><a href="http://stompandstammer.com/category/news-leak/" class="menu-link sub-menu-link">News Leak</a></li>
<li id="nav--top__item-7704" class="nav__item depth-1 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent hidden"><a href="http://stompandstammer.com/category/support-our-troops/" class="menu-link sub-menu-link">Support Our Troops</a></li>
<li id="nav--top__item-5650" class="nav__item depth-1 menu-item menu-item-type-taxonomy menu-item-object-category hidden"><a href="http://stompandstammer.com/category/call-sheet/" class="menu-link sub-menu-link">Call Sheet</a></li>
<li id="nav--top__item-2868" class="nav__item depth-1 menu-item menu-item-type-taxonomy menu-item-object-category hidden"><a href="http://stompandstammer.com/category/concert-calendar/" class="menu-link sub-menu-link">Get Out!</a></li>
<li id="nav--top__item-7705" class="nav__item depth-1 menu-item menu-item-type-custom menu-item-object-custom hidden"><a href="http://bandsiusetalike.com" class="menu-link sub-menu-link">Bands I Useta Like</a></li>
</ul>
</li>
</ul>            </div>
        </nav>

    </div>

</header><!-- .header -->
    <div class="container container--main" itemprop="mainEntity" itemscope itemtype="http://schema.org/BlogPosting">

    <div class="grid">

    
    <div class="grid__item  float--left  two-thirds  palm-one-whole  article__featured-image" itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
        <meta itemprop="url" content="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/jermaine-1050x600.jpg"/>
        <meta itemprop="width" content="1050"/>
        <meta itemprop="height" content="600"/>
        <div class="image-wrap" style="padding-top: 57.1428571429%">
	                        <img class="riloadr-single" data-src-big="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/jermaine-1050x600.jpg" data-src-small="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/jermaine-335x191.jpg" alt="Jermaine" />
			        </div>
    </div><!-- .article__featured-image -->


    <article class="post-article  js-post-gallery  grid__item  main  float--left  lap-and-up-two-thirds">
    	<h1 class="article__title  article__title--single" itemprop="name headline">So So Def Turns 25</h1>

<div class="article__title__meta">
	<meta itemprop="datePublished" content="2018-02-26T19:10:35+00:00" />
    	<meta itemprop="dateModified" content="2018-02-26T19:12:29+00:00" />
    
			<div class="article__author-name" itemprop="author" itemscope itemtype="http://schema.org/Person"><span itemprop="name"><a href="http://stompandstammer.com/author/stompydude/" title="Posts by Jeff Clark" itemprop="sameAs">Jeff Clark</a></span></div>		<time class="article__time" datetime="2018-02-26T19:10:35+00:00"> on February 26, 2018 at 7:10 pm</time>
	</div><!-- .article__title__meta -->

    <p>2018 marks 25 years since Atlanta musician/songwriter/producer Jermaine Dupri founded So So Def Recordings as an offshoot of his production company. Commemorating that milestone, Sony Music’s hip-hop/R&amp;B reissue division Certified Classics is releasing the vinyl/digital compilation album <em>So So Def 25</em> this summer, packed with hits, remixes and deep cuts from the likes of Kris Kross, Xscape, Lil’ Bow Wow, Da Brat, Jagged Edge and others.</p>
<p>Vinyl reissues of selected albums from the label’s back catalog are also planned throughout the year, as is an all-star So So Def tour of some sort. Details are still being hammered out.</p>

    <div class="grid"><!--
                        --></div>

        
        <div class="article__meta  article--single__meta">
                                <div class="btn-list">
                        <div class="btn  btn--small  btn--secondary"></div>
                        <a href="" class="btn  btn--small  btn--primary"></a>
                    </div>
                                <div class="btn-list">
                    <div class="btn  btn--small  btn--secondary">Categories</div>
                    <a class="btn  btn--small  btn--tertiary" href="http://stompandstammer.com/category/support-our-troops/" title="View all posts in Support Our Troops">Support Our Troops</a>                </div>
                            <div class="btn-list">
                    <div class="btn  btn--small  btn--secondary">Tagged</div>
                    <a class="btn  btn--small  btn--tertiary" href="http://stompandstammer.com/tag/atlanta/" title="View all posts tagged Atlanta">Atlanta</a><a class="btn  btn--small  btn--tertiary" href="http://stompandstammer.com/tag/bow-wow/" title="View all posts tagged Bow Wow">Bow Wow</a><a class="btn  btn--small  btn--tertiary" href="http://stompandstammer.com/tag/da-brat/" title="View all posts tagged Da Brat">Da Brat</a><a class="btn  btn--small  btn--tertiary" href="http://stompandstammer.com/tag/georgia/" title="View all posts tagged Georgia">Georgia</a><a class="btn  btn--small  btn--tertiary" href="http://stompandstammer.com/tag/hip-hop/" title="View all posts tagged Hip-Hop">Hip-Hop</a><a class="btn  btn--small  btn--tertiary" href="http://stompandstammer.com/tag/jagged-edge/" title="View all posts tagged Jagged Edge">Jagged Edge</a><a class="btn  btn--small  btn--tertiary" href="http://stompandstammer.com/tag/jermaine-dupri/" title="View all posts tagged Jermaine Dupri">Jermaine Dupri</a><a class="btn  btn--small  btn--tertiary" href="http://stompandstammer.com/tag/kris-kross/" title="View all posts tagged Kris Kross">Kris Kross</a><a class="btn  btn--small  btn--tertiary" href="http://stompandstammer.com/tag/rap/" title="View all posts tagged Rap">Rap</a><a class="btn  btn--small  btn--tertiary" href="http://stompandstammer.com/tag/rhythm-and-blues/" title="View all posts tagged Rhythm and Blues">Rhythm and Blues</a><a class="btn  btn--small  btn--tertiary" href="http://stompandstammer.com/tag/so-so-def/" title="View all posts tagged So So Def">So So Def</a><a class="btn  btn--small  btn--tertiary" href="http://stompandstammer.com/tag/xscape/" title="View all posts tagged Xscape">Xscape</a>                </div>
                    </div>
        
<div id="share-box" class="share-box">
	<div id="pixlikes" class="share-item pixlikes-box likes-box likeable "  data-id="8036" >
	<div class="share-item__icon like-link"><i class="pixcode pixcode--icon icon-e-heart  circle  small"></i></div>
	<div class="share-item__value likes-count  likes-text">0</div>
</div>
	<div class="addthis_toolbox addthis_default_style addthis_32x32_style  add_this_list"
	     addthis:url="http://stompandstammer.com/support-our-troops/def-turns-25/"
	     addthis:title="So So Def Turns 25 - Support Our Troops - Stomp And Stammer"
	     addthis:description="2018 marks 25 years since Atlanta musician/songwriter/producer Jermaine Dupri founded . . ."><a class="addthis_button_compact"></a><a class="addthis_button_preferred_1"></a><a class="addthis_button_preferred_2"></a><a class="addthis_button_preferred_3"></a><a class="addthis_button_preferred_4"></a>	</div>
</div>
<hr class="separator  separator--subsection">        
            <nav class="post-nav  grid"><!--
                                        --><div class="post-nav-link  post-nav-link--prev  grid__item  one-whole  lap-and-up-one-half">
                    <a href="http://stompandstammer.com/record-reviews/noel-gallaghers-high-flying-birds-built-moon/">
                                <span class="post-nav-link__label">
                                    Previous Article                                </span>
                                <span class="post-nav-link__title">
                                    <h3 class="hN">Noel Gallagher's High Flying Birds – Who Built the Moon?</h3>
                                </span>
                    </a>
                </div><!--
                    --><div class="post-nav-link  post-nav-link--blank  grid__item  one-whole  lap-and-up-one-half">
                    &nbsp;
                </div><!--
                                    --></nav>

        
        <hr class="separator  separator--section">

        <div class='yarpp-related'>


    <div class="related-projects_items-list-container">
        <div class="comments-area-title">
            <h4 class="hN"><em>Related</em> Articles</h4>
        </div>
                    <ul class="related-projects_items-list grid"><!--
                            --><li class="related-projects_item grid__item one-half lap-and-up-one-quarter">

                     <article class="article article--billboard-small">
                                                <a href="http://stompandstammer.com/support-our-troops/zac-brown-thinks-hes-bruno-mars/">
                            <div class="article__thumb">
                                <img class="lazy" data-src="http://stompandstammer.com/wp16/wp-content/uploads/2017/11/sir_rosevelt_diego_pernia-203x157.jpg" alt="img" />
                            </div>
                            <div class="article__content">
                                <h2 class="article__title article--billboard-small__title">
                                    <span class="hN">Zac Brown Thinks He&#8217;s Bruno Mars</span>
                                </h2>
                                <span class="article__description">
                                    Dahlonega’s own three-time Grammy winner and fried . . .                                </span>
                                <span class="small-link">Read More<em>+</em></span>
                            </div> 
                        </a>
                    </article>

                </li><!--
                            --><li class="related-projects_item grid__item one-half lap-and-up-one-quarter">

                     <article class="article article--billboard-small">
                                                <a href="http://stompandstammer.com/support-our-troops/bruce-hampton-live-album-released/">
                            <div class="article__thumb">
                                <img class="lazy" data-src="http://stompandstammer.com/wp16/wp-content/uploads/2017/12/bruce_hampton_cover-203x157.jpg" alt="img" />
                            </div>
                            <div class="article__content">
                                <h2 class="article__title article--billboard-small__title">
                                    <span class="hN">Bruce Hampton Live Album Released</span>
                                </h2>
                                <span class="article__description">
                                    During the last months of his life, Col. Bruce Hampton . . .                                </span>
                                <span class="small-link">Read More<em>+</em></span>
                            </div> 
                        </a>
                    </article>

                </li><!--
                            --><li class="related-projects_item grid__item one-half lap-and-up-one-quarter">

                     <article class="article article--billboard-small">
                                                <a href="http://stompandstammer.com/support-our-troops/st-beauty-blends-retro-modern/">
                            <div class="article__thumb">
                                <img class="lazy" data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/st_beauty-203x157.jpg" alt="img" />
                            </div>
                            <div class="article__content">
                                <h2 class="article__title article--billboard-small__title">
                                    <span class="hN">St. Beauty Blends Retro, Modern</span>
                                </h2>
                                <span class="article__description">
                                    Atlanta-based R&amp;B duo St. Beauty bend pop’s ru . . .                                </span>
                                <span class="small-link">Read More<em>+</em></span>
                            </div> 
                        </a>
                    </article>

                </li><!--
                            --><li class="related-projects_item grid__item one-half lap-and-up-one-quarter">

                     <article class="article article--billboard-small">
                                                <a href="http://stompandstammer.com/support-our-troops/darryl-rhoades-funny-aint-payin-bills/">
                            <div class="article__thumb">
                                <img class="lazy" data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/darryl_rhoades-203x157.jpg" alt="img" />
                            </div>
                            <div class="article__content">
                                <h2 class="article__title article--billboard-small__title">
                                    <span class="hN">Darryl Rhoades: Funny Ain&#8217;t Payin&#8217; the Bills</span>
                                </h2>
                                <span class="article__description">
                                    Darryl Rhoades used to be Atlanta’s funnyman, a sa . . .                                </span>
                                <span class="small-link">Read More<em>+</em></span>
                            </div> 
                        </a>
                    </article>

                </li><!--
                        --></ul>

            </div>
</div>
    </article><!--

                 --><div class="grid__item  one-third  palm-one-whole  sidebar">
        <div id="text-4" class="widget  widget--main widget_text">			<div class="textwidget"><div class="g g-1"><div class="g-single a-15"><a href="http://www.starbaratlanta.com" target="_blank"><img src="https://i2.wp.com/stompandstammer.com/wp16/wp-content/uploads/2017/10/starbarbanner_300x60.jpg" /></a></div></div></div>
		</div><div id="wpgrade_popular_posts-2" class="widget  widget--main wpgrade_popular_posts"><div class="widget__title  widget--sidebar__title"><h2 class="hN">Popular</h2></div>
		<ul class="tabs__nav  popular-posts__time">
							<li><a class="current" href="#daily" data-time="daily" data-numberposts="5" data-thumb="72" data-tab="popular">Today</a></li>
							<li><a class="" href="#weekly" data-time="weekly" data-numberposts="5" data-thumb="72" data-tab="popular">Week</a></li>
							<li><a class="" href="#monthly" data-time="monthly" data-numberposts="5" data-thumb="72" data-tab="popular">Month</a></li>
							<li><a class="" href="#all" data-time="all" data-numberposts="5" data-thumb="72" data-tab="popular">All</a></li>
					</ul>

		<div class="tabs__content">
			<div class="tabs__pane " id="daily">			<article class="article  article--list">
				<a href="http://stompandstammer.com/concert-calendar/get-february-26-march-4/" title="Get Out! February 26 – March 4" class="article--list__link">
											<div class="media__img  push-half--right">
							<img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/noel_gallagher_lawrence_watson-72x54.jpg" alt="Get Out! February 26 – March 4"  class="popular-posts-widget__img lazy " />
						</div>
										<div class="media__body">
						<div class="article__title  article--list__title">
							<h5 class="hN">Get Out! February 26 – March 4</h5>
						</div>
					</div>
					<div class="badge  badge--article  badge--article--list">1</div>
				</a>
			</article>
						<article class="article  article--list">
				<a href="http://stompandstammer.com/movie-reviews/black-panther/" title="Black Panther" class="article--list__link">
											<div class="media__img  push-half--right">
							<img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/black_panther-72x54.jpg" alt="Black Panther"  class="popular-posts-widget__img lazy " />
						</div>
										<div class="media__body">
						<div class="article__title  article--list__title">
							<h5 class="hN">Black Panther</h5>
						</div>
					</div>
					<div class="badge  badge--article  badge--article--list">2</div>
				</a>
			</article>
						<article class="article  article--list">
				<a href="http://stompandstammer.com/call-sheet/twisted-affair-dolly-otto-now-filming/" title="Twisted Affair Dolly & Otto Now Filming" class="article--list__link">
											<div class="media__img  push-half--right">
							<img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2017/08/molly_burnett-72x54.jpg" alt="Twisted Affair Dolly &#038; Otto Now Filming"  class="popular-posts-widget__img lazy " />
						</div>
										<div class="media__body">
						<div class="article__title  article--list__title">
							<h5 class="hN">Twisted Affair Dolly & Otto Now Filming</h5>
						</div>
					</div>
					<div class="badge  badge--article  badge--article--list">3</div>
				</a>
			</article>
						<article class="article  article--list">
				<a href="http://stompandstammer.com/record-reviews/noel-gallaghers-high-flying-birds-built-moon/" title="Noel Gallagher's High Flying Birds – Who Built the Moon?" class="article--list__link">
											<div class="media__img  push-half--right">
							<img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/cover_ngallagher_moon-72x54.jpg" alt="Noel Gallagher&#8217;s High Flying Birds – Who Built the Moon?"  class="popular-posts-widget__img lazy " />
						</div>
										<div class="media__body">
						<div class="article__title  article--list__title">
							<h5 class="hN">Noel Gallagher's High Flying Birds – Who Built the Moon?</h5>
						</div>
					</div>
					<div class="badge  badge--article  badge--article--list">4</div>
				</a>
			</article>
						<article class="article  article--list">
				<a href="http://stompandstammer.com/call-sheet/bobby-brown-story-told/" title="Bobby Brown Story To Be Told" class="article--list__link">
											<div class="media__img  push-half--right">
							<img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/woody_mcclain-72x54.jpg" alt="Bobby Brown Story To Be Told"  class="popular-posts-widget__img lazy " />
						</div>
										<div class="media__body">
						<div class="article__title  article--list__title">
							<h5 class="hN">Bobby Brown Story To Be Told</h5>
						</div>
					</div>
					<div class="badge  badge--article  badge--article--list">5</div>
				</a>
			</article>
			</div><div class="tabs__pane hide" id="weekly">			<article class="article  article--list">
				<a href="http://stompandstammer.com/call-sheet/bobby-brown-story-told/" title="Bobby Brown Story To Be Told" class="article--list__link">
											<div class="media__img  push-half--right">
							<img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/woody_mcclain-72x54.jpg" alt="Bobby Brown Story To Be Told"  class="popular-posts-widget__img lazy " />
						</div>
										<div class="media__body">
						<div class="article__title  article--list__title">
							<h5 class="hN">Bobby Brown Story To Be Told</h5>
						</div>
					</div>
					<div class="badge  badge--article  badge--article--list">1</div>
				</a>
			</article>
						<article class="article  article--list">
				<a href="http://stompandstammer.com/concert-calendar/get-february-19-february-25/" title="Get Out! February 19 – February 25" class="article--list__link">
											<div class="media__img  push-half--right">
							<img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/bebel_gilberto-72x54.jpg" alt="Get Out! February 19 – February 25"  class="popular-posts-widget__img lazy " />
						</div>
										<div class="media__body">
						<div class="article__title  article--list__title">
							<h5 class="hN">Get Out! February 19 – February 25</h5>
						</div>
					</div>
					<div class="badge  badge--article  badge--article--list">2</div>
				</a>
			</article>
						<article class="article  article--list">
				<a href="http://stompandstammer.com/movie-reviews/black-panther/" title="Black Panther" class="article--list__link">
											<div class="media__img  push-half--right">
							<img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/black_panther-72x54.jpg" alt="Black Panther"  class="popular-posts-widget__img lazy " />
						</div>
										<div class="media__body">
						<div class="article__title  article--list__title">
							<h5 class="hN">Black Panther</h5>
						</div>
					</div>
					<div class="badge  badge--article  badge--article--list">3</div>
				</a>
			</article>
						<article class="article  article--list">
				<a href="http://stompandstammer.com/call-sheet/hellfest-haunt-atlanta/" title="Hellfest to Haunt Atlanta" class="article--list__link">
											<div class="media__img  push-half--right">
							<img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/hellfest-72x54.jpg" alt="Hellfest to Haunt Atlanta"  class="popular-posts-widget__img lazy " />
						</div>
										<div class="media__body">
						<div class="article__title  article--list__title">
							<h5 class="hN">Hellfest to Haunt Atlanta</h5>
						</div>
					</div>
					<div class="badge  badge--article  badge--article--list">4</div>
				</a>
			</article>
						<article class="article  article--list">
				<a href="http://stompandstammer.com/feature-stories/black-lips/" title="Black Lips" class="article--list__link">
											<div class="media__img  push-half--right">
							<img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2017/05/black_lips_horiz2_tim_song-72x54.jpg" alt="Black Lips"  class="popular-posts-widget__img lazy " />
						</div>
										<div class="media__body">
						<div class="article__title  article--list__title">
							<h5 class="hN">Black Lips</h5>
						</div>
					</div>
					<div class="badge  badge--article  badge--article--list">5</div>
				</a>
			</article>
			</div><div class="tabs__pane hide" id="monthly">			<article class="article  article--list">
				<a href="http://stompandstammer.com/feature-stories/marillion/" title="Marillion" class="article--list__link">
											<div class="media__img  push-half--right">
							<img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/marillion_freddy_billqvis-72x54.jpg" alt="Marillion"  class="popular-posts-widget__img lazy " />
						</div>
										<div class="media__body">
						<div class="article__title  article--list__title">
							<h5 class="hN">Marillion</h5>
						</div>
					</div>
					<div class="badge  badge--article  badge--article--list">1</div>
				</a>
			</article>
						<article class="article  article--list">
				<a href="http://stompandstammer.com/news-leak/nrbqs-debut-reissued-first-time/" title="NRBQ's Debut Reissued for First Time" class="article--list__link">
											<div class="media__img  push-half--right">
							<img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/nrbq_phil_crandon-72x54.jpg" alt="NRBQ&#8217;s Debut Reissued for First Time"  class="popular-posts-widget__img lazy " />
						</div>
										<div class="media__body">
						<div class="article__title  article--list__title">
							<h5 class="hN">NRBQ's Debut Reissued for First Time</h5>
						</div>
					</div>
					<div class="badge  badge--article  badge--article--list">2</div>
				</a>
			</article>
						<article class="article  article--list">
				<a href="http://stompandstammer.com/movie-reviews/black-panther/" title="Black Panther" class="article--list__link">
											<div class="media__img  push-half--right">
							<img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/black_panther-72x54.jpg" alt="Black Panther"  class="popular-posts-widget__img lazy " />
						</div>
										<div class="media__body">
						<div class="article__title  article--list__title">
							<h5 class="hN">Black Panther</h5>
						</div>
					</div>
					<div class="badge  badge--article  badge--article--list">3</div>
				</a>
			</article>
						<article class="article  article--list">
				<a href="http://stompandstammer.com/call-sheet/futuristic-thriller-gemini-man-eyes-savannah/" title="Futuristic Thriller Gemini Man Eyes Savannah" class="article--list__link">
											<div class="media__img  push-half--right">
							<img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2017/11/will_smith-72x54.jpg" alt="Futuristic Thriller Gemini Man Eyes Savannah"  class="popular-posts-widget__img lazy " />
						</div>
										<div class="media__body">
						<div class="article__title  article--list__title">
							<h5 class="hN">Futuristic Thriller Gemini Man Eyes Savannah</h5>
						</div>
					</div>
					<div class="badge  badge--article  badge--article--list">4</div>
				</a>
			</article>
						<article class="article  article--list">
				<a href="http://stompandstammer.com/call-sheet/resident-reside-atlanta/" title="The Resident to Reside in Atlanta" class="article--list__link">
											<div class="media__img  push-half--right">
							<img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2017/08/resident-72x54.jpg" alt="The Resident to Reside in Atlanta"  class="popular-posts-widget__img lazy " />
						</div>
										<div class="media__body">
						<div class="article__title  article--list__title">
							<h5 class="hN">The Resident to Reside in Atlanta</h5>
						</div>
					</div>
					<div class="badge  badge--article  badge--article--list">5</div>
				</a>
			</article>
			</div><div class="tabs__pane hide" id="all">			<article class="article  article--list">
				<a href="http://stompandstammer.com/call-sheet/reba-mcentire-abc-pilot-film-georgia/" title="Reba McEntire ABC Pilot to Film in Georgia" class="article--list__link">
											<div class="media__img  push-half--right">
							<img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2017/02/reba_mcentire_jeremycowart-72x54.jpg" alt="Reba McEntire ABC Pilot to Film in Georgia"  class="popular-posts-widget__img lazy " />
						</div>
										<div class="media__body">
						<div class="article__title  article--list__title">
							<h5 class="hN">Reba McEntire ABC Pilot to Film in Georgia</h5>
						</div>
					</div>
					<div class="badge  badge--article  badge--article--list">1</div>
				</a>
			</article>
						<article class="article  article--list">
				<a href="http://stompandstammer.com/call-sheet/no-one-asked-honey-4/" title="Because No One Asked For It: Honey 4" class="article--list__link">
											<div class="media__img  push-half--right">
							<img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2017/02/honey_series-72x54.jpg" alt="Because No One Asked For It: Honey 4"  class="popular-posts-widget__img lazy " />
						</div>
										<div class="media__body">
						<div class="article__title  article--list__title">
							<h5 class="hN">Because No One Asked For It: Honey 4</h5>
						</div>
					</div>
					<div class="badge  badge--article  badge--article--list">2</div>
				</a>
			</article>
						<article class="article  article--list">
				<a href="http://stompandstammer.com/feature-stories/ben-haggard/" title="Ben Haggard" class="article--list__link">
											<div class="media__img  push-half--right">
							<img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2018/01/ben_haggard-72x54.jpg" alt="Ben Haggard"  class="popular-posts-widget__img lazy " />
						</div>
										<div class="media__body">
						<div class="article__title  article--list__title">
							<h5 class="hN">Ben Haggard</h5>
						</div>
					</div>
					<div class="badge  badge--article  badge--article--list">3</div>
				</a>
			</article>
						<article class="article  article--list">
				<a href="http://stompandstammer.com/support-our-troops/video-premiere-metal-mcdonald-keeps-running-hills/" title="Video Premiere: Metal McDonald "It Keeps You Running (To The Hills)"" class="article--list__link">
											<div class="media__img  push-half--right">
							<img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2016/12/metal_mcdonald-72x54.jpg" alt="Video Premiere: Metal McDonald &#8220;It Keeps You Running (To The Hills)&#8221;"  class="popular-posts-widget__img lazy " />
						</div>
										<div class="media__body">
						<div class="article__title  article--list__title">
							<h5 class="hN">Video Premiere: Metal McDonald "It Keeps You Running (To The Hills)"</h5>
						</div>
					</div>
					<div class="badge  badge--article  badge--article--list">4</div>
				</a>
			</article>
						<article class="article  article--list">
				<a href="http://stompandstammer.com/feature-stories/black-lips/" title="Black Lips" class="article--list__link">
											<div class="media__img  push-half--right">
							<img data-src="http://stompandstammer.com/wp16/wp-content/uploads/2017/05/black_lips_horiz2_tim_song-72x54.jpg" alt="Black Lips"  class="popular-posts-widget__img lazy " />
						</div>
										<div class="media__body">
						<div class="article__title  article--list__title">
							<h5 class="hN">Black Lips</h5>
						</div>
					</div>
					<div class="badge  badge--article  badge--article--list">5</div>
				</a>
			</article>
			</div>		</div>

		</div><div id="text-3" class="widget  widget--main widget_text">			<div class="textwidget"><script async src="http://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Med. Rectangle Side Bar -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-6681116909085824"
     data-ad-slot="7024629394"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</div><div id="wpgrade_latest_reviews-2" class="widget  widget--main widget_wpgrade_latest_reviews">							<div class="widget__title  widget--sidebar__title  flush--bottom">
					<h2 class="hN">Latest Reviews</h2>
				</div>
						<ol class="reviews">
									<li class="review">
						<article>
							<a class="review__title" href="http://stompandstammer.com/record-reviews/brian-fallon-painkillers/">Brian Fallon – Painkillers</a>
														<span class="badge  badge--review">8.9</span>
							<div class="progressbar"><div class="progressbar__progress" style="width: 89%;"></div></div>
						</article>
					</li>
									<li class="review">
						<article>
							<a class="review__title" href="http://stompandstammer.com/record-reviews/pj-harvey-the-hope-six-demolition-project/">PJ Harvey &#8211; The Hope Six Demolition Project</a>
														<span class="badge  badge--review">9.3</span>
							<div class="progressbar"><div class="progressbar__progress" style="width: 93%;"></div></div>
						</article>
					</li>
									<li class="review">
						<article>
							<a class="review__title" href="http://stompandstammer.com/record-reviews/iggy-pop-post-pop-depression/">Iggy Pop &#8211; Post Pop Depression</a>
														<span class="badge  badge--review">6.9</span>
							<div class="progressbar"><div class="progressbar__progress" style="width: 69%;"></div></div>
						</article>
					</li>
									<li class="review">
						<article>
							<a class="review__title" href="http://stompandstammer.com/record-reviews/frankie-cosmos-next-thing/">Frankie Cosmos &#8211; Next Thing</a>
														<span class="badge  badge--review">7.3</span>
							<div class="progressbar"><div class="progressbar__progress" style="width: 73%;"></div></div>
						</article>
					</li>
									<li class="review">
						<article>
							<a class="review__title" href="http://stompandstammer.com/record-reviews/eleanor-friedberger-new-view/">Eleanor Friedberger &#8211; New View</a>
														<span class="badge  badge--review">8</span>
							<div class="progressbar"><div class="progressbar__progress" style="width: 80%;"></div></div>
						</article>
					</li>
							</ol>
		</div><div id="wpgrade_posts_slider_widget-3" class="widget  widget--main widget_wpgrade_posts_slider_widget"><div class="widget__title  widget--sidebar__title"><h2 class="hN">Latest Articles</h2></div>			<div class="pixslider  js-pixslider" data-autoheight data-arrows>
									<div class="article  article--slider">
						<div class="image-wrap">
															<img src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/jermaine-335x256.jpg" alt="So So Def Turns 25" />
													</div>
						<div class="article__title  article--slider__title">
							<h3 class="hN"><a href="http://stompandstammer.com/support-our-troops/def-turns-25/">So So Def Turns 25</a></h3>
						</div>
						<div class="article__meta  article--slider__meta">
							<div class="split">
								<div class="split__title  article__category">
									<a class="small-link" href="http://stompandstammer.com/category/support-our-troops/" title="View all posts in Support Our Troops">Support Our Troops</a>								</div>
								<ul class="nav  article__meta-links">
									<li class="xpost_date"><i class="icon-time"></i> 26 Feb</li>
																		<li class="xpost_likes"><i class="icon-heart"></i> 0</li>
																	</ul>
							</div>
						</div>
					</div>
									<div class="article  article--slider">
						<div class="image-wrap">
															<img src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/cover_ngallagher_moon-335x256.jpg" alt="Noel Gallagher&#8217;s High Flying Birds – Who Built the Moon?" />
													</div>
						<div class="article__title  article--slider__title">
							<h3 class="hN"><a href="http://stompandstammer.com/record-reviews/noel-gallaghers-high-flying-birds-built-moon/">Noel Gallagher&#8217;s High Flying Birds – Who Built the Moon?</a></h3>
						</div>
						<div class="article__meta  article--slider__meta">
							<div class="split">
								<div class="split__title  article__category">
									<a class="small-link" href="http://stompandstammer.com/category/record-reviews/" title="View all posts in Record Reviews">Record Reviews</a>								</div>
								<ul class="nav  article__meta-links">
									<li class="xpost_date"><i class="icon-time"></i> 25 Feb</li>
																		<li class="xpost_likes"><i class="icon-heart"></i> 0</li>
																	</ul>
							</div>
						</div>
					</div>
									<div class="article  article--slider">
						<div class="image-wrap">
															<img src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/noel_gallagher_lawrence_watson-335x256.jpg" alt="Get Out! February 26 – March 4" />
													</div>
						<div class="article__title  article--slider__title">
							<h3 class="hN"><a href="http://stompandstammer.com/concert-calendar/get-february-26-march-4/">Get Out! February 26 – March 4</a></h3>
						</div>
						<div class="article__meta  article--slider__meta">
							<div class="split">
								<div class="split__title  article__category">
									<a class="small-link" href="http://stompandstammer.com/category/concert-calendar/" title="View all posts in Get Out!">Get Out!</a>								</div>
								<ul class="nav  article__meta-links">
									<li class="xpost_date"><i class="icon-time"></i> 25 Feb</li>
																		<li class="xpost_likes"><i class="icon-heart"></i> 0</li>
																	</ul>
							</div>
						</div>
					</div>
									<div class="article  article--slider">
						<div class="image-wrap">
															<img src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/la_luz_vikesh_kapoor-335x256.jpg" alt="New La Luz? Fabulous Nuz!" />
													</div>
						<div class="article__title  article--slider__title">
							<h3 class="hN"><a href="http://stompandstammer.com/news-leak/new-la-luz-fabulous-nuz/">New La Luz? Fabulous Nuz!</a></h3>
						</div>
						<div class="article__meta  article--slider__meta">
							<div class="split">
								<div class="split__title  article__category">
									<a class="small-link" href="http://stompandstammer.com/category/news-leak/" title="View all posts in News Leak">News Leak</a>								</div>
								<ul class="nav  article__meta-links">
									<li class="xpost_date"><i class="icon-time"></i> 24 Feb</li>
																		<li class="xpost_likes"><i class="icon-heart"></i> 0</li>
																	</ul>
							</div>
						</div>
					</div>
									<div class="article  article--slider">
						<div class="image-wrap">
															<img src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/game_night-335x256.jpg" alt="Game Night" />
													</div>
						<div class="article__title  article--slider__title">
							<h3 class="hN"><a href="http://stompandstammer.com/movie-reviews/game-night/">Game Night</a></h3>
						</div>
						<div class="article__meta  article--slider__meta">
							<div class="split">
								<div class="split__title  article__category">
									<a class="small-link" href="http://stompandstammer.com/category/movie-reviews/" title="View all posts in Movie Reviews">Movie Reviews</a>								</div>
								<ul class="nav  article__meta-links">
									<li class="xpost_date"><i class="icon-time"></i> 24 Feb</li>
																		<li class="xpost_likes"><i class="icon-heart"></i> 0</li>
																	</ul>
							</div>
						</div>
					</div>
									<div class="article  article--slider">
						<div class="image-wrap">
															<img src="http://stompandstammer.com/wp16/wp-content/uploads/2018/02/emmanuelle_chriqui-335x256.jpg" alt="The Passage Reshooting in Atlanta" />
													</div>
						<div class="article__title  article--slider__title">
							<h3 class="hN"><a href="http://stompandstammer.com/call-sheet/passage-reshooting-atlanta/">The Passage Reshooting in Atlanta</a></h3>
						</div>
						<div class="article__meta  article--slider__meta">
							<div class="split">
								<div class="split__title  article__category">
									<a class="small-link" href="http://stompandstammer.com/category/call-sheet/" title="View all posts in Call Sheet">Call Sheet</a>								</div>
								<ul class="nav  article__meta-links">
									<li class="xpost_date"><i class="icon-time"></i> 23 Feb</li>
																		<li class="xpost_likes"><i class="icon-heart"></i> 0</li>
																	</ul>
							</div>
						</div>
					</div>
							</div>
		</div>    </div>
    
    </div>
    </div>

   
    </div><!-- .wrapper --> 
    
        <div class="site__stats">
        <div class="container">
        
                        <div class="back-to-top"><a href="#page">Back to Top</a></div>
                    </div>
    </div>
        
    <footer class="site__footer">
        
        <h2 class="accessibility"></h2>
		
    	
            <div class="footer__sidebar">

                <div class="container">
                    
                    <div class="footer__widget-area  grid"><!--
                                                 --><div class="grid__item one-third  palm-one-whole">
                                <div id="text-2" class="widget_text  widget  widget-area__first  widget--footer"><div class="widget__title  widget--footer__title"><h3 class="hN">Latest Issue</h3></div>			<div class="textwidget"><p><img class="alignleft" src="http://stompandstammer.com/wp16/wp-content/uploads/2018/01/magcover_18_02_small.jpg" /></p>
</div>
		</div>                            </div><!--
                                                                            --><div class="grid__item one-third  palm-one-whole">
                                <div id="wpgrade_social_links-2" class="widget_wpgrade_social_links  widget  widget-area__first  widget--footer">			<div class="widget__title  widget--footer__title"><h3 class="hN">Follow Us</h3></div>			<div class="btn-list">
										<a href="https://twitter.com/stompandstammer" target="_blank">
							<i class="pixcode  pixcode--icon  icon-e-twitter square medium"></i>
						</a>
											<a href="https://www.facebook.com/Stomp-and-Stammer-26104709043/" target="_blank">
							<i class="pixcode  pixcode--icon  icon-e-facebook square medium"></i>
						</a>
								</div>
		</div><div id="pages-2" class="widget_pages  widget  widget-area__first  widget--footer"><div class="widget__title  widget--footer__title"><h3 class="hN">Buy Stuff</h3></div>		<ul>
			<li class="page_item page-item-4850"><a href="http://stompandstammer.com/back-issues/">Back Issues</a></li>
<li class="page_item page-item-4830"><a href="http://stompandstammer.com/subscribe/">Subscriptions</a></li>
		</ul>
		</div>                            </div><!--
                                                                            --><div class="grid__item one-third  palm-one-whole">
                                <div id="search-3" class="widget_search  widget  widget-area__first  widget--footer"><div class="widget__title  widget--footer__title"><h3 class="hN">Search</h3></div><form class="form-search" method="get" action="http://stompandstammer.com/" role="search">
    <input class="search-query" type="text" name="s" id="s" placeholder="Search..." autocomplete="off" value="" /><!--
    --><button class="btn search-submit" id="searchsubmit"><i class="icon-search"></i></button>
</form></div>                            </div><!--
                                         --></div>
                    
                    <div class="footer__widget-area  grid"><!--

                        
                                                
                 --></div>

                </div>

            </div>

    			
        <div class="footer__copyright">
            <div class="container">
                <div class="flexbox">
                    <div class="footer-copyright flexbox__item">©2017, Stomp And Stammer Magazine. All Rights Reserved.
Website by <a title="NYC WordPress Agency" href="http://www.code18.com" target="_blank" rel="noopener noreferrer">Code18 Interactive</a>.</div>
                    <div class="footer-menu flexbox__item "><ul id="menu-footer-menu" class="site-navigation site-navigation--footer site-navigation--secondary flush--bottom nav nav--block"><li id="menu-item-4222" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4222"><a href="http://www.stompandstammer.com/downloads/2017_media_kit.pdf">Advertise</a></li>
<li id="menu-item-4214" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4214"><a href="http://stompandstammer.com/contact-us/">Contact Us</a></li>
</ul></div>
                </div>
            </div>
        </div>

    </footer><!-- .site__footer -->
    
    </div><!-- #page -->
<link rel='stylesheet' id='yarppRelatedCss-css'  href='http://stompandstammer.com/wp16/wp-content/plugins/yet-another-related-posts-plugin/style/related.css?ver=4.9.4' type='text/css' media='all' />
<script type='text/javascript' src='http://stompandstammer.com/wp16/wp-content/themes/bucket/theme-content/js/woocommerce.js?ver=201705200148'></script>
<script type='text/javascript' src='http://pxgcdn.com/js/rs/9.5.7/index.js?ver=4.9.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajaxurl = "http:\/\/stompandstammer.com\/wp16\/wp-admin\/admin-ajax.php";
var sharrre_urlCurl = "http:\/\/stompandstammer.com\/wp16\/wp-content\/themes\/bucket\/theme-content\/js\/sharrre.php";
var objectl10n = {"tPrev":"Previous (Left arrow key)","tNext":"Next (Right arrow key)","tCounter":"of"};
var theme_name = "bucket";
/* ]]> */
</script>
<script type='text/javascript' src='http://stompandstammer.com/wp16/wp-content/themes/bucket/theme-content/js/main.js?ver=1.6.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"http:\/\/stompandstammer.com\/wp16\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://stompandstammer.com/wp16/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201809'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var locals = {"ajax_url":"http:\/\/stompandstammer.com\/wp16\/wp-admin\/admin-ajax.php","ajax_nounce":"f6a023a78c","load_likes_with_ajax":"","already_voted_msg":"You already voted!","like_on_action":"click","hover_time":"1000","free_votes":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://stompandstammer.com/wp16/wp-content/plugins/pixlikes/js/public.js?ver=1.0.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wc_add_to_cart_params = {"ajax_url":"\/wp16\/wp-admin\/admin-ajax.php","wc_ajax_url":"http:\/\/stompandstammer.com\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"http:\/\/stompandstammer.com\/cart\/","is_cart":"","cart_redirect_after_add":"yes"};
/* ]]> */
</script>
<script type='text/javascript' src='http://stompandstammer.com/wp16/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js?ver=3.2.6'></script>
<script type='text/javascript' src='http://stompandstammer.com/wp16/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.70'></script>
<script type='text/javascript' src='http://stompandstammer.com/wp16/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js?ver=2.1.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var woocommerce_params = {"ajax_url":"\/wp16\/wp-admin\/admin-ajax.php","wc_ajax_url":"http:\/\/stompandstammer.com\/?wc-ajax=%%endpoint%%"};
/* ]]> */
</script>
<script type='text/javascript' src='http://stompandstammer.com/wp16/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js?ver=3.2.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wc_cart_fragments_params = {"ajax_url":"\/wp16\/wp-admin\/admin-ajax.php","wc_ajax_url":"http:\/\/stompandstammer.com\/?wc-ajax=%%endpoint%%","fragment_name":"wc_fragments_36d2fd549a11458810452c0b7a403813"};
/* ]]> */
</script>
<script type='text/javascript' src='http://stompandstammer.com/wp16/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js?ver=3.2.6'></script>
<script type='text/javascript' src='//s7.addthis.com/js/300/addthis_widget.js#async=1'></script>
<script type='text/javascript' src='http://stompandstammer.com/wp16/wp-includes/js/wp-embed.min.js?ver=4.9.4'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201809.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.7',blog:'108032862',post:'8036',tz:'-5',srv:'stompandstammer.com'} ]);
	_stq.push([ 'clickTrackerInit', '108032862', '8036' ]);
</script>
<script type="text/javascript">
;(function($){
                                            
})(jQuery);
</script>
</body>
</html>